[Opendnssec-user] ODS 2.0.1 did not start after reboot.

Wytze van der Raay wytze at deboca.net
Tue Aug 30 08:12:48 UTC 2016

On 08/30/2016 09:46 AM, Fred.Zwarts wrote:
> ODS 2.0.1 has now been running satisfactory on our test system for several
> weeks. However, recently we noticed that each time we reboot the system,
> ods does not startup properly. It turns out that after each reboot, the
> directory /var/run/opendnssec has disappeared, so opendnssec can not start,
> because it wants to create sock and pid files in this directory. I have
> worked around this problem, by modifying /usr/local/sbin/ods-control, where
> I added a mkdir for this directory just before the startup of the
> enforcer.
> It is not clear to me how this directory disappears. The test system runs
> SLES 12 SP1.
> I hope that this information helps to improve this software.

I recognize the problem ... we are running ODS 2.0.1 on OpenSUSE 13.2,
which is presumably quite similar to SLES 12 SP1. The /var/run directory
is a symbolic link to the /run directory. /run is created as tmpfs on
every reboot, ie its content does not persist. This change has been made in
SUSE and several other Linux distros to accomodate systemd, see for example
for some background.

I *think* that if one uses a proper systemd script for starting/stopping ODS,
it is possible to have the opendnssec directory created automatically more or
less, but my current hack is to put a "mkdir -p /var/run/opendnssec" in its
(oldfashioned init-style) startup script. The same issue exists with nsd,
and I solved it in the same way.

In any case, this is not something that should be solved in
/usr/local/sbin/ods-control, but rather in the distro-specific packaging scripts
for ODS.

Wytze van der Raay

More information about the Opendnssec-user mailing list