[Opendnssec-user] SoftHSM installation / Token Initialization

simran singh kyoonn at hotmail.com
Sat Feb 18 00:13:20 UTC 2012

Hello Paul,

Thanks for your prompt reply. I have not tried installing using yum since I am eventually also trying to install this on a dev platform that
will not have yum. Is there way I can have softhsm include the botan libraries which are currently under /usr/local/lib.
Thank you


> Date: Fri, 17 Feb 2012 19:00:21 -0500
> From: paul at nohats.ca
> To: kyoonn at hotmail.com
> CC: opendnssec-user at lists.opendnssec.org
> Subject: Re: [Opendnssec-user] SoftHSM installation / Token Initialization
> On Fri, 17 Feb 2012, simran singh wrote:
> > I am not sure if this is the right list to post this. I have successfully installed softhsm but 
> > when I try to intialize the token or try to do any softhsm command, I get the following error:
> > 
> > # softhsm --init-token --slot0 --label "My token 1"
> > softhsm: error while loading shared libraries: libbotan-1.10.so.0: cannot open shared object file: No such
> > file or directory
> > 
> > I have installed Botan 1.10 correctly but still get the error. I am following instructions that are
> > provided in the README for softhsm.
> If those libs got installed in /usr/local/lib, your /etc/ld.iso.conf (or
> /etc/ld.so.conf.d/) might not be including /usr/local/lib
> Lots of distros include botan already, did you try apt-get or yum to
> install it? For RHEL/Fedora you need to activate the epel repository
> (but then you can also just yum install softhsm)
> Paul
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opendnssec.org/pipermail/opendnssec-user/attachments/20120217/9bea6849/attachment.htm>

More information about the Opendnssec-user mailing list