[Opendnssec-user] Error when running make - Solved

Sven-Åke Svensson sa at mbg.se
Thu Jan 14 15:57:36 CET 2010


You were right. There was dual versions of sqlite3 installed. After 
fixing that I could build and install.
So the next step is to get it up running but that's another story.

Thank you for your help


sion at nominet.org.uk skrev:
>> I am trying to build opendnssec but I get an error when I rum "make". I
>> run on a Cent OS Linux 2.6.18-164.el5.
>> I have installed dependencies by following the instructions on this
>> site.
> http://trac.opendnssec.org/wiki/Signer/Using/Installation/Dependencies
>> Configuring using "./configure" runs without error but make stops with
>> the follpwing lines:
>> ../ksm/libksm.a(database_access_lite.o): In function
>> `DbExecuteSqlStatement':
>> /home/sven/opendnssec-1.0.0rc2/enforcer/ksm/database_access_lite.c:103:
>> undefined reference to `sqlite3_prepare_v2'
>> I tried to find something at Google but no luck.
> We run on centos here; there is an issue with the version of sqlite3 which
> ships with centos in that it is too old and doesn't provide the
> sqlite3_prepare_v2 call.
> I thought that this was picked up during configuration, so is it possible
> that you have more than one version of sqlite3 installed?
> If you look at the output from configure (run it just in the enforcer
> directory) there should be some hints as to where it is looking.
> Sion

More information about the Opendnssec-user mailing list