[Opendnssec-user]ods-signer failed when ods-signerd is running

刘硕 shuoleo at 126.com
Wed Jul 18 06:08:49 UTC 2012

Hi Jerry,
I found out where the problem was, the ods-signerd was down so the engine.socket disappeared.
I have installed 1.4.0a2,1.3.9 and now I'm using the trunk!
If ods-signerd is running, then I run ods-signerd seems do nothing at all, but sometimes there are more than one ods-signerd process at the same time! I don't this situation would affect opendnssec's signing work, because I think some ods-signerd would do the work at a mixed period.
Thought I don't know why ods-signerd sometimes goes down, but sometimes I run ods-signer sign --all, there would be an error reads "Unable to connect to engine: connect() failed: No such file or directory"

[root at CST-BJ-104: :/var/opendnssec]$ps -aux | grep ods
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.8/FAQ
root      3955  0.0  0.0  40660  5536 ?        SLs  Jul12   0:06 /usr/local/sbin/ods-enforcerd
root     12080  0.0  1.0 1022852 81536 ?       SLsl Jul13   1:23 ods-signerd
root     23225  0.0  0.0 103236   812 pts/2    S+   20:43   0:00 grep ods
[root at CST-BJ-104: :/var/opendnssec]$ods-signer zones
Unable to connect to engine: connect() failed: No such file or directory

But you see the ods-signerd is running!
Do you know what the problem is?

Best regards,

From: Jerry Lundstr鰉
Date: 2012-07-17 14:44
To: shuoleo
CC: opendnssec-user
Subject: Re: Re: [Opendnssec-user]ods-signer failed when ods-signerd is running
Hi Stuart,

On Tue, Jul 17, 2012 at 4:20 AM, 刘硕 <shuoleo at 126.com> wrote:
>>Are you sure one is not looking for the socket at the wrong place due to
>>mismatched install, eg /var/run/opendnssec/engine.sock versus
>>/local/var/run/opendnssec/engine.sock? Can you strace the ods-signer
>>command to see where it is trying to find the socket?
> Maybe there is a problem with my installation, I did not find anything in
> /var/run/opendnssec, not to say engie.sock.
> I just installed opendnssec and its dependencies with the guidance on the
> wiki. Any thing wrong?

The ps output looks weird, how did you start OpenDNSSEC?

Can you run: which ods-signerd

What distribution/OS is this?

Have you installed OpenDNSSEC on to this machine prior to this installation?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opendnssec.org/pipermail/opendnssec-user/attachments/20120718/e250f0b7/attachment.htm>

More information about the Opendnssec-user mailing list