[Opendnssec-user] Issues when building OpenDNSSEC 1.2: Ruby xsd/datatypes not found

Carlos M. Martinez carlos at lacnic.net
Thu Feb 17 14:39:32 UTC 2011

Hello all, I think I have solved the issue for me. If anyone is
interested, read below:

> On 16 Feb 2011, at 13:51, Carlos M. Martinez wrote:
>>> configure: Detecting common OpenDNSSEC settings
>>> checking for ruby... /home/opendnssec/bin/ruby
>>> checking for ruby library syslog... ok
>>> checking for ruby library openssl... ok
>>> checking for ruby library xsd/datatypes... not found
>>> configure: error: Ruby library 'xsd/datatypes' not found
>>> configure: error: ./configure failed for auditor
Apparently xsd/datatypes.rb is part of a gem called XSD4R. I could not
find a way to install XSD4R alone, but installing another gem called
SOAP4R solved the problem as it appears to include XSD4R.

I had previously installed a gem called xmlparser, so it may or may not
be needed, I'm not exactly sure.

So, my solution in the end was:

gem install -r rake
-- had install xmlparser from source due to my non-standard install
location (it could not find expat and libxml2)
gem install -r soap4r

Warm regards,


Carlos M. Martinez
PGP KeyID 0xD51507A2
Phone: +598-2604-2222 ext. 4419

-------------- next part --------------
A non-text attachment was scrubbed...
Name: carlos.vcf
Type: text/x-vcard
Size: 204 bytes
Desc: not available
URL: <http://lists.opendnssec.org/pipermail/opendnssec-user/attachments/20110217/16a4ee67/attachment.vcf>

More information about the Opendnssec-user mailing list