[Opendnssec-maintainers] supported sqlite3 version

John Dickinson jad at sinodun.com
Wed Apr 10 12:16:52 UTC 2013


The OpenDNSSEC developers would like your input on the impact of changing the required version of sqlite3 in future releases of OpenDNSSEC (v1.3, v1.4 and v2). Currently the enforcer checks for at least sqlite3 >= 3.3.9 which is very old.

We would like to raise this requirement to sqlite3 >= 3.7.0 as this would allow us to:
1. Enforce foreign key constraints. http://www.sqlite.org/foreignkeys.html
2. Make use of the WAL to better handle locking issues. http://www.sqlite.org/wal.html

Impact of this change:

RHEL and derivatives ship with 3.6.20
Ubuntu 10.04 LTS ships with 3.6.22

Users of these OS's would need to install/upgrade sqlite3. Users on recent *BSD or Solaris 11 should be OK.

(BTW SoftHSM will be tested against sqlite3 >= 3.7.0 before any change is made to the OpenDNSSEC requirements.)


More information about the Opendnssec-maintainers mailing list