[Opendnssec-develop] libhsm: parts renamed during 2.0 work
Rick van Rein
rick at openfortress.nl
Tue May 20 13:19:30 UTC 2014
> The name hsm_key describes it perfectly, because its a database object
> with the HSM key content. It was called HSM key in protobuf also but it
> was C++ stil so it was HsmKey.
So the protobuf-originated code is the new one. Changing that is less heavy on the project, esp. regarding porting of patches.
> I would like to have the database object called hsm_key and the libhsm
> stuff prefixed with libhsm because that clearly separates the
I rather disagree. The prefix “libhsm_” instead of “hsm_” focusses on the minor detail of it being a library, whereas the point of the “hsm_” prefix is to focus on the idea of having an API to the HSM.
These two reasons means that I vote for Matthijs’ proposal.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 204 bytes
Desc: Message signed with OpenPGP using GPGMail
More information about the Opendnssec-develop