[Opendnssec-develop] libhsm: parts renamed during 2.0 work

Sara Dickinson sara at sinodun.com
Tue May 20 16:35:45 UTC 2014

On 20 May 2014, at 14:19, Rick van Rein <rick at openfortress.nl> wrote:

> Hi,
>> The name hsm_key describes it perfectly, because its a database object
>> with the HSM key content. It was called HSM key in protobuf also but it
>> was C++ stil so it was HsmKey.
> So the protobuf-originated code is the new one.  Changing that is less heavy on the project, esp. regarding porting of patches.

FWIIW I agree with Rick here. Changing the name of the DB object is less work, less risk and has zero impact on our production releases. Also the object is not actually an hsm key, it is a representation of an hsm key in the enforcer db so I don’t think the naming should be so precious. Call it hsm_key_wrapper, hsm_key_descriptor, enforcer_hsm_key_ref,...? Surely you can be creative enough to solve this the simple way :-)


More information about the Opendnssec-develop mailing list